Bloomreach Experience Manager V14.7.1 Detailed Release Notes

December 13, 2021

The new maintenance release of 14.7.1 is available for general use for our customers and partners. This release includes new features, bug fixes, and improvements in core, enterprise and plugin artifacts.

We encourage all projects to update to the most recent regular releases. Using a tagged artifact that is not yet part of a release should only be done if there is a specific reason and only after testing in your specific project setup.

Update considerations

The following 3rd party dependencies have changed since the previous maintenance release. If your project directly uses any of these libraries, please validate compatability. For more information on changes in these  libraries please see information from the invidual vendors.

Module 14.7.0 14.7.1
org.apache.logging.log4j/log4j-api 2.13.3 2.15.0
org.apache.logging.log4j/log4j-core 2.13.3 2.15.0
org.apache.logging.log4j/log4j-1.2-api 2.13.3 2.15.0
org.apache.logging.log4j/log4j-slf4j-impl 2.13.3 2.15.0
net.bytebuddy/byte-buddy 1.9.3 1.10.14
org.javassist/javassist 3.24.0-GA 3.27.0-GA

Overview of JIRA issues closed in Bloomreach Experience 14.7.1

Improvement

  • ENT-3836 ] - [eforms] Enterprise Forms: make MailFormDataBehavior more robust

Bug

  • CMS-14880 ] - [cms] [Backport 14.x/15.x] Allow unknown namespace to be used in "nodetypes" option of NodePickerController
  • CMS-14877 ] - [navigation-application] Sometimes JS Console error appears In this configuration Angular requires Zone.js
  • CMS-14866 ] - [site-toolkit] PageModelAggregationValve v1.0: Add a null check for component parameter values
  • CMS-14864 ] - [site-toolkit] DocumentQueryDynamicComponent: default value for pageSize cannot be overridden
  • CMS-14711 ] - [site-toolkit] WARN "Component class not loadable" in out-of-the-box xpage rendering

Task

  • CMS-14901 ] - [project] Bump log4j to the latest release
  • CMS-14898 ] - [project] Update Javadoc copyright statement to be Bloomreach
  • CMS-14888 ] - [site-toolkit] Bump jooq from 0.9.12 to 0.9.14
  • CMS-14887 ] - [l10n-tooling] Bump maven-plugin-plugin from 3.6.0 to 3.6.2
  • CMS-14886 ] - [configuration-management, release] For FileSystems.newFileSystem cast null to ClassLoader to avoid build errors with Java 17
  • CMS-14873 ] - [archetype] Remove explicit hippo.hst.version from archetype hst-addon-hcm-site dependency

 

Totals for issues in this release

  • Improvements 1
  • Bugs 5
  • Tasks 6
Did you find this page helpful?
How could this documentation serve you better?
On this page
    Did you find this page helpful?
    How could this documentation serve you better?

    We rely on cookies

    to optimize our communication and to enhance your customer experience. By clicking on the Accept and Close button, you agree to the collection of cookies. You can also adjust your preferences by clicking on Manage Preferences. For more information please see our Privacy policy.

    Manage cookies
    Accept & close

    Cookies preferences

    Accept & close
    Back